In Autocad 2015 for Mac, I have created a cylinder with a torus wrapped around it. The torus is 2 mm thick, with 1 mm embedded inside the cylinder and 1 mm outside. I want to subtract the torus from the cylinder, so I will be left with a semicircular groove around the cylinder. I have already done this once, but I had to remake the object so I deleted the original and started again - and now when I try to subtract the torus, it simply deletes the torus and leaves the cylinder untouched. What is going wrong, and how can I fix it?


Often this sort of problem is caused by some small and non-obvious error in your drawing, for example if a point hasn't snapped to exactly where you expected to one or more lines aren't exactly in the right place. Particularly if you end up with open loops or small gaps between lines which should intersect. You can also have problems if you have several lines or points on top of each other.

Most CAD software has a tool to diagnose these sorts of problems.

Another common problem is picking/entity selection errors, these can sometimes crop up from minor conflicts with graphics processing eg some software prefers Nvidia to Radeon graphics hardware which can sometimes cause odd problems.

Probably the first thing is to look at your basic geometry and make sure that it is what it is supposed to be. The second is to look back through your workflow and make sure that you have done everything properly. It is very easy with CAD to slip into bad habits where you do things which are a bit iffy and work in some circumstances but not others. Similarly is is very easy when learning to get yourself into a wrong mode or layer or assign an unwanted property to an object.

Autocad is also well supported by online forums so it may also be worth asking your question there as well.


To be honest this came entirely from chance and I still have NO idea what caused the problem. The answer by @ChrisJohns will probably be a more likely cause of the issue, as for me I'm simply going to put it down to a bug, because this is how I fixed it:

Turn it off and on again. Make your torus/etc and put it in place, but if subtract doesn't work, undo the subtraction, save, quit, reopen and try it again, one subtraction at a time. Like I said, no idea what the cause is, so if this still doesn't work take a look at @ChrisJohns answer


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.