2
$\begingroup$

I am simulating a turbine that has curves. Mesh is structure completely. But there is high skewness in tip clearance and some parts of around of the blade:

enter image description here

When I use SIMPLEC Method, one factor (Skewness correction) appear under the SIMPLEC method in ANSYS Fluents method.

How I must adjust this factor? I dont know which number must be set? 1< or 1 , 2, 3?

I used K-e turbulence model and when I set Skewness correction to 5 or 20, the following error is appeared:

"Error: Divergence detected in AMG solver: k

Error: Divergence detected in AMG solver: k Error Object: #f"

Why does this happen?

Please suggest a way to reduce the skewness in ansys fluent and how can I check Skewness in Fluent?

$\endgroup$
1
$\begingroup$

First try setting skewness correction to 0, and see if Fluent produces a converged solution. If not, then you have other problems that need to be addressed first. If it converges, then increase skewness correction to 1 or 2 and retry. To address the error regarding divergence in the AMG solver, try reducing your pressure correction under-relaxation factor to less than 1.0, like 0.8 or 0.7. This will require more iterations but will be more tolerant of skewed cells.

I'm sorry I don't have any advice based on hard theory to give you. I usually just end up playing around with different settings in Fluent until I get it to work. If you have a tech support contract with ANSYS, their support staff are very knowledgeable and usually can spot problems in a Fluent model pretty quickly.

| improve this answer | |
$\endgroup$
1
$\begingroup$
  • firstly you have ensue that the mesh quality is good.
  • try to reduce Under Relaxation Factors to values less than defaults.
| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.