1
$\begingroup$

I am using a servo motor 130st-M15015LB with the AASD-30A driver. I have to use the acceleration with position control mode. I can see in the documentation that If I use Pn110 to Pn112, I can have a time of acceleration between 5 to 1750ms, but when I try, it doesn't work, (it works until 500ms +-), I have been trying to solve this problem for one week, but I really don't understand (I'm a software developer). If someone can help me, that would be great!

Example, I tried:

With the combination of Pn110 = 400, Pn111 = 300, Pn112 = 100 It works,

but when I put Pn110 = 1500, Pn111 = 1200, Pn112 = 300 It doesn't work, the AASD-30A driver say that I cannot use these parameters,

(Sorry for my English)

$\endgroup$
4
  • $\begingroup$ And what happens when you go outside the operating range of the acceleration time? $\endgroup$
    – dtn
    Apr 4, 2023 at 10:54
  • $\begingroup$ I controle with some codes (modbus communication), so I receive error from the driver (slave), so when I go over 500, It said "Slave reported illegal data value" and it doesn't run the motor. But according to the document, I can go up to 1750 $\endgroup$ Apr 4, 2023 at 11:55
  • $\begingroup$ As far as I understood from what I read on the Internet, most of the parameters (112 and 113 for example) are paired, that is, one is responsible for the parameters when rotating in one direction, the other, respectively, in the other direction. But there is some really useful information on these drives, I didn't study them well. When setting up controllers (once upon a time), I tried to identify the relationship between the parameters, trying to achieve the desired settings for my purposes. And it was very painstaking, since one parameter is non-linearly dependent on the other. $\endgroup$
    – dtn
    Apr 6, 2023 at 4:17
  • $\begingroup$ So for each parameter, I have to ask me if there is a connection with these three acceleration parameters? Yes it's arduous. $\endgroup$ Apr 7, 2023 at 12:07

1 Answer 1

0
$\begingroup$

Update

The servo motor and his driver are fake, so some registers didn't work, it's normal.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.