2
$\begingroup$

I want to preface this by saying I am software engineer so each part of this robot build has been a lesson on its own. From welding, to CAD design, pillow block bearings, etc, etc....

I am working on a DIY Rover using the following components:

  • 4 DC Motors from electric scooters: 24V, 250W. Connected to axle with #40 roller chains and sprockets.
  • 4 Lawn Mower Wheels. They are 16x6.50-8 for a 3/4" axle with a keyway
  • A Pair of 12 Volt - 60Ah GEL Batteries : I pulled them from a discarded electric wheel chair. They are fully charged, and they show 26V when connected in series
  • I replaced the stock sprockets on the motors with these #40 chain 12 teeth, 1/2" pitch.
  • I put the same sprockets on the axles

enter image description here enter image description here enter image description here

The problem is that the robot does not begin to move. When I lift the wheel off the ground, they move fine, and spin fast depending on how much throttle I give them.

However on the ground they don't move, which is typically a torque problem.

However I am not so convinced because these motors are supposed to be for electric scooters and each one capable of moving an adult person, weighing 175+ lbs.

Here are my diagnostic steps:

  1. Using a FLYSKY controller and 12x2 Sabertooth motor controller. Unfortunately this controller has an over current protection, and those batteries are massive, so it just shuts itself down whenever I move throttle just a little bit. But again, when the wheels are off the ground they are spinning fine, so the connections are fine.
  2. To avoid the over-current protection problem, I purchased this 60Amp DC Motor Controller. I connected it to just one wheel so far, and spliced a Multimeter into the connection to measure voltage. I can see the motor will get up to 20V when I turn the Potentiometer dial, and I can see the car begin to try to move.

Another question is: what's a good way to measure how many Amps the motor is trying to pull?

My conclusions are:

  • The chains are just too heavy for this motor. It's a #40 chain which is way overkill. The sprocket on the motor shaft and the axle are also too heavy
  • The tires maybe too heavy. But again, it's 4 x 250W motor that's getting 24V and probably up to 10Amps

What is your advice?

What would you do to fix this problem with minimal changes to the design? I.e. just replacing the sprockets? Or are the tires also too heavy?

How would I keep the tires and motors as is? Replace the sprockets and chains? Figure out a way to give a higher initial Amperage?

$\endgroup$

2 Answers 2

4
$\begingroup$

The motors have a rated speed of 2750rpm. It doesn't look like there's much of a gear ratio, so at the moment the motors spin at the same speed as the wheels. With 16" wheels, 2750rpm is about 130mph (rpm*diameter*pi, then converting inches/minute to mph). I'm guessing you don't want it to go that fast, and that speed wouldn't be possible with a total power of 1kw, or 1.3hp.

So you want to gear the motors down a lot, which increases the wheel torque. If you want a design speed of say 20mph, that's a gear ratio of $\frac{130}{20}=6.5$, so the wheel sprocket should have 6.5 times as many teeth as the motor sprocket and be 6.5 times the diameter.

That will also give you 6.5 times as much torque at the wheels

$\endgroup$
6
  • $\begingroup$ Thanks! I suspected it's a Torque problem with bad gear ratio, but I was hoping for a simpler solution. thanks again! $\endgroup$ Jun 9 at 12:13
  • 1
    $\begingroup$ You could find a motor with an internal gearbox that's designed for a lower speed, if you don't mind throwing more money at it! Or a gearbox that goes between the motor and sprocket $\endgroup$
    – sqek
    Jun 9 at 12:15
  • $\begingroup$ I actually have 4 of those motors from electric wheel chairs I found on the road; where the batteries came from. However I wanted to save those for the next version of the bot, since I already had these 4 motors. I wanted to make as many mistakes on this one, then re-do everything clean with those geared motors $\endgroup$ Jun 9 at 12:19
  • 1
    $\begingroup$ Smaller wheels = lower speed and more force - think of design speed = wheel rpm * wheel diameter * pi, *60$\frac{hours}{minute}$ / 63360 \frac{inches}{mile}$. To get a 'design speed' of 20mph without gearing would need 2.5" wheels though, 6" wheels would still get a speed of ~50mph when the motors are spinning at their design speed, but might be enough to get it moving - just don't expect much load capacity or acceleration $\endgroup$
    – sqek
    Jun 9 at 12:25
  • 1
    $\begingroup$ Another way to estimate: 250W@2750rpm=0.87Nm of motor torque. Force=torque/radius, so with a 6" diameter (7.5cm radius) wheel you'd get a total force of ~45N, or 4.5kg(f). Push it with the same force it'd take to lift 4.5kg and see if it moves $\endgroup$
    – sqek
    Jun 9 at 12:37
1
$\begingroup$

I would swap the gears between the motor and the shaft, as it looks like you are trying to drive the axle shaft faster than the motor.

If you have a small gear on the motor and a larger (*3 or *4) gear on the shaft then the motor should be able to start the device moving. Of course, the will limit the top speed.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.