0
$\begingroup$

I have been out of SolidWorks CAD modeling for some time. Recently started getting into some more intense CAD modeling in SolidWorks 2021 and noticed that the mouse controls have changed. I tried some internet searching, but I evidently don't know the right keywords.

The old system would allow you to view the model from any angle in 3D space. You could click the center mouse wheel and rotate the mouse clockwise or counter clockwise to index the model. It was a bit non-intuitive to starting out, but powerful for getting the exact view you wanted. This is the best video I found and it was in 2019. Notice how as he rotates the mouse clockwise the model also rotates. https://youtu.be/FTQZBDIv6gs?t=52

Currently in 2021, the model always returns to the upright position and this ability to rotate the model to any angle has been removed (at least in the default settings). I put together this youtube video real quick of the navigation issue I am having: https://youtu.be/wmfQ4pdB-j8

Is there some setting I need to turn off/on? Is there some new and improved way to view models from any angle in space that supersedes the old method?

$\endgroup$
5
  • $\begingroup$ Sadly I started using SW in 2011 so don't know what you're talking about but - the arrow keys rotate the model in steps, and pressing alt spins the existing view, and pressing the space bar brings up a handy view cube you can click on to snap to all sorts of views. Perhaps one of these is the superseded method you are thinking of? $\endgroup$ Jan 15 at 8:46
  • $\begingroup$ 90% of my navigation is done by rotating freehand, and then if I want exactly square on for any reason, I use "normal to" (CTRL+8 by default, I remapped to F8) $\endgroup$ Jan 15 at 8:47
  • $\begingroup$ @JonathanRSwift, Thanks! Yeah freehand is my preferred method too, but somehow my settings seem to be nerfed. Maybe old is not the right word, I found a video of how it should (IMO) work from 2019 (edited in question). I also just screen captured my issue and uploaded it to youtube (link also added in question). $\endgroup$
    – ericnutsch
    Jan 15 at 10:12
  • 1
    $\begingroup$ Thanks for the video - really helpful. You are stuck in "rotate about entity" see blogs.solidworks.com/solidworksblog/2009/11/… note how the mouse symbol on your screen shows an axis - try pressing escape a few times to make sure nothing is selected? $\endgroup$ Jan 15 at 11:28
  • 1
    $\begingroup$ To be clear - the default settings in 2021 still work as you want them to - so that's good news at least! $\endgroup$ Jan 15 at 11:29

1 Answer 1

1
$\begingroup$

I've found the setting which you inadvertently have selected - it's called "Rotate About Scene Floor" Simply right click off the model in the graphics area, and uncheck this option.

Rotate About Scene Floor

The reason one might choose this - is that it makes the camera rotation behave in a more similar way to some rendering packages. Users who are used to that environment will be as frustrated trying the 'normal way' as you were this way.

$\endgroup$
1
  • $\begingroup$ Thanks! I'm so glad it was just me and the functionality didn't go away! $\endgroup$
    – ericnutsch
    Jan 15 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.