2
$\begingroup$

Using the sylvac UL 4 Each time I invoke the (send data) function the sylvac LED panel reports 'no.data'. To mention the obvious but nothing is received at the connected USB device.

My question is. . How do force the sylvac device to (have data) to send? Can anyone explain what this 'no.data' actually means from the calipers perspective?

enter image description here

$\endgroup$
1
  • $\begingroup$ I've updated the answer with a solution. Please check it below. $\endgroup$
    – msysmilu
    Oct 27 '20 at 14:22
1
$\begingroup$

As briefly mentioned above, you need to either connect the caliper to one of the software "masters" offered by Sylvac, or use the caliper in HId mode.

Select your model from this page: Sylvac Hand Tools.

Download the appropriate manual; the other answers here do not refer to your appropriate model manual.

Enable the HId mode through a sequence that might look like this below. Please note that some calipers don't have HId mode.

enter image description here

$\endgroup$
1
$\begingroup$

This might be a good place to start

enter image description here

Take a look at IOT-Ready Sylvac Bluetooth® Profiles, and SYLVAC BLUETOOTH IOT 4.0 / KEYBOARD INPUT FUNCTION. WIRELESS DATA TRANSFER

$\endgroup$
1
  • $\begingroup$ This doesn't answer the OP question. If anything, the instructions from Sylvac are disorganized at best, and don't work in the same manner on all devices (definitely not on mine). $\endgroup$
    – msysmilu
    Mar 24 '20 at 10:05
1
$\begingroup$

No.data: Value could not be sent via Bluetooth® Technology. Check the Bluetooth® connection on instrument and master device (on/off). Check if you are within the max. transmission range 5-15m.

https://www.sylvac.ch/faq?view=topic&id=2

I have now resolved this issue in my case: the caliper's BT connection needs to be set up using the app that Sylvac has made for this. Note, if you've used the phone's BT procedure, it's the wrong way.

https://play.google.com/store/apps/details?id=ch.sylvac.Anywhere

$\endgroup$
0
$\begingroup$

Not sure if this is the sole cause for this (no.Data) error but. . . Sitting the Bluetooth profile to (Hld) - (Virtual Keyboard) seems to have corrected this issue. Measurement data arrives (in the app that has focus / cursor) as if this caliper were a keyboard attached to the PC. Very smooth and nice with a carriage return - linefeed appended.

$\endgroup$
2
  • $\begingroup$ Any idea on how to get into the HId mode? (the manual is really not accurate) $\endgroup$
    – msysmilu
    Mar 24 '20 at 10:06
  • $\begingroup$ Not all models have an HID mode. Mine doesn't. $\endgroup$
    – msysmilu
    Oct 26 '20 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.