3
$\begingroup$

I am using a BeagleBone Black, Revision B with a 4D Systems LCD touch screen. The screen worked initially with a stock Angstrom or Debian distribution but I want to use Android instead.

I tried to use all of the pre-built Android images from Texas Instruments for the 4D screen, but I can not boot anymore. There is nothing on the screen. I tried to boot on the 4D screen via HDMI.

I am writing the image to the SD card with ./mkmmc-android.sh /dev/sdb.

Additional details:

BBB_Ubuntu_Screen_OP
Click on image for a larger version of the image.

Note: This is a screen capture from above e2e.ti.com forum link

$\endgroup$
1
  • $\begingroup$ Muzeyyen - Embedded and Software Engineering are on-topic subjects for the site, but "I don't know how to troubleshoot" is off-topic as it's too broad. Engineering.SE is built around specific, answerable Q&A and is not meant for interactive troubleshooting sessions. If you can narrow your question to a specific problem, then this may be able to be re-opened. $\endgroup$
    – user16
    Apr 14 '15 at 14:29
3
$\begingroup$

Base on the information provide try shorting the jumpers on the 4D Systems LCD Display. As best as I know Android LCD cape only recognizes the LCD at a specific address. I believe there is EEPROM information in the LCD cape that is required to complete the android boot up process (Verification required for this sentence).

Below is picture to help locate the jumpers

4D Systems Jumpers
Click on image for a larger version of the image.

Below are excerpts from the 4D Systems LCD 4DCAPE-43T data sheet for

EEPROM Shunt EEPROM Jumpers

Assumptions:

  • Beaglebone Black + 4D System LCD worked with stock Angstrom or Debian distribution
  • 4D System LCD is of model 4DCAPE-43T
  • Android distribution is 4.2.2 (Jelly Bean)
  • Ubuntu is the host system

An image of the Beaglebone black + 4D Systems with Angstrom distribution

Beaglebone black + 4D System with Angstrom

Debugging Tips

  • Make sure the you have good micro SD Card, that is 4GB. I have had issue with poor quality SD Cards
  • Configure and use minicom to log in as root
  • If you are using external power supply make sure the supply is rated at sufficiently (800 mA will work, it is best to be able to source at least 1A or 2A)
  • Connect both the external and USB power supply for boot-up
  • Monitor the boot of process using a FTDI serial debugging cable

Serial Debugging Cable

FTDI Debugging Cable

External Power Supply

External Power Supply

Click on image for a larger version of the image.

You can purchase a serial debugging cable from adafruit, sparkfun, or other DIY online stores.

References:

$\endgroup$
0

Not the answer you're looking for? Browse other questions tagged or ask your own question.