1
$\begingroup$

Using Abaqus 6.12-1, I am trying to submit a restart job with an added step. I've followed exactly the instructions in section 19.6.5 of Abaqus 6.12-1 CAE user's manual, but receive this error:

A node set with the same name "ASSEMBLY_SEM-2D-PART-1_Fixed Nodes" defined in the original analysis has been redefined in the current analysis. Existing sets cannot be modified in a restart analysis.

Looking at the input file for job-2, I see that this is in fact true, Two Nsets used for BCs have been redefined. One is used for a displacement and the other for an encastre. I did not modify these sets in any way. I also checked the .rpy file and it didn't report any changes to sets.

I intend to modify the value for the displacement in the added step. However, to isolate the problem, I have tried the following, none of which have worked.:

  1. Not modifying the value for the displacement (propagating it).
  2. Deactivating the displacement in the added step.
  3. Adding a deactivated step in the original model and activating it upon restart.

Why does this happen?

Also, my end goal is to do this in a Python script. Modifying an input file (manually or programmatically) is not an option.

I can work around the problem as per agentp's comment and many helpful comments on this LinkedIn page. The problem, however, remains unsolved. I'll leave the question open for anyone with the same problem or with a solution to see.

$\endgroup$
2
  • $\begingroup$ The input file required for a restart is typically only a few lines. Much easier than monkeying around with CAE. Why rule that out? $\endgroup$
    – agentp
    Dec 8 '16 at 22:25
  • $\begingroup$ @agentp because then I would have to write all changes to the input file manually. Using CAE/Python, I simply activate a step, and all new Load/BC/Interactions are written automatically. $\endgroup$ Dec 9 '16 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.